frame-relay map ip x.x.x.x dlci broadcast OR frame-relay interface-dlci

 =============================
frame-relay show commands
=============================
R2#sh frame lmi
LMI Statistics for interface Serial1 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 14               Num Status msgs Rcvd 14
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:47         Last Full Status Rcvd 00:00:47
R2#sh frame pvc
PVC Statistics for interface Serial1 (Frame Relay DTE)
              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0
DLCI = 221, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1.123
  input pkts 0             output pkts 0            in bytes 0        
  out bytes 0              dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 0         out bcast bytes 0        
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 05:30:57, last time pvc status changed 00:21:00
R2#sh frame map
Serial1.123 (up): ip 172.12.123.1 dlci 221(0xDD,0x34D0), static,
              broadcast,
              CISCO, status defined, active
Serial1.123 (up): ip 172.12.123.3 dlci 221(0xDD,0x34D0), static,
              broadcast,
              CISCO, status defined, active
R2#
==============================
============================== 
 

 

frc3-4fin.png

 

 

 

 

My View on Frame-Relay:

Frame-relay can be very weird.  The hard thing about frame-relay is “which frame-relay command do I use?” is the question.

The answer to the question is simple: You can use which one you want as long as all the PVC mappings are complete and connect to the correct router interface.  You can mix and match frame-relay commands. Just run a ping command to each PVC (ip address) and run your debug commands:

show frame map – Should see word “Active”  if working well.
show frame pvc   –
show frame lmi    –  Sent/Received should be equal amount if working

Static Mappings Command:

frame-relay map ip (remote ip address) (local dlci) broadcast

frame-relay map ip 172.12.123.1 201 broadcast

NOTE: Broadcast is used with this command to allow RIP updates to work. But, if “frame-relay inverse-arp” is used and inverse-arp is turned on, then the command “broadcast” is not needed.

Dynamic Mappings Command:

frame-relay interface-dlci (local dlci) 

frame-relay interface-dlci 201

frame-relay inverse-arp (enabled)

NOTE: frame-relay inverse-arp used to allow for dynamic mappings. 

If you look at the drawing I have given you, it explains the difference between the “actual” and the “virtual/logical” layout of the frame-relay setup. What you see is not what you actually get. When I first saw the “Full-Mesh” I thought there were three actual physical ports on each router. This is not true. You have instead 3 virtual or 3 sub-interfaces on each router that set up a PVCs to each router. I think this is essential when teaching or learning frame-relay. Remember that they are virtual/logical mappings not separate physical ports.

NOTE: You need ‘broadcast’ command with “frame-relay map ip” command when using RIPv1 since it uses broadcasts to send out routing table information.

NOTE: The hard thing now is to know when to use the right frame-relay command mentioned above and which type of port setup:

Port setup types:                                              Example:

Serial Port only                                                  Serial0
Serial Port with Multipoint option                       Serial0.1 multipoint
Serial Port with Point-to-Point option                Serial0.1 point-to-point

Other important Commands:

no frame-relay inverse-arp

You need “broadcast” command to allow RIP updates to  take place.

frame-relay inverse-arp

No need for “broadcast” command here. 

frame-relay lmi-type (ansi, cisco, q933a)

 Keep lmi types the same on both ends. 

encapsulation frame-relay (can use – “ietf”)

Keep encap “frame-relay” for frame-relay connections

 

Example of R1 (Full-mesh) Frame-relay topology:

frc-1f.png

 

 

 

 

Subinterfaces on R1:

R1(config)#interface serial 0

R1(config-if)#encapsulation frame-relay

R1(config-if)#no shutdown

R1(config-if)#interface serial0.200 point-to-point

R1(config-subif)#frame-relay interface-dlci 102

R1(config-subif)#ip address 172.16.1.1 255.255.255.0

R1(config-subif)#no shutdown

———————————-

R1(config-if)#interface serial0.300 point-to-point

R1(config-subif)#frame-relay interface-dlci 103

R1(config-subif)#ip address 172.16.3.1 255.255.255.0

R1(config-subif)#no shutdown

———————————

R1(config-if)#interface serial0.400 point-to-point

R1(config-subif)#frame-relay interface-dlci 104

R1(config-subif)#ip address 172.16.4.1 255.255.255.0

R1(config-subif)#no shutdown

 ————————————————————–

Frame Relay YouTube nice! Below (Double Click to expand video Full Screen

————————————————————–

 www.palaestratraining.com

 

H2o Fuel…Answer to get rid USA dependency on OPEC oil–OPEC Sucks!!!

Advertisements

7 Responses to “frame-relay map ip x.x.x.x dlci broadcast OR frame-relay interface-dlci”

  1. Aragoen Celtdra Says:

    Yo! Daddy-O! What do you use to illustrate your network diagrams? I use visio at work but I’m thinking there might be a much ligher-weight program that can do the job.

  2. yo aragoen, I like visio too and yes I really like using what is called
    network notepad. I will find the link. It is super easy to use and light weight. What I do is I after buidling a design do a print screen so it is big and t he I cut and paste into my Paint.net program and crop it and save it as a png file so I can have it for my website. works great! plus it is easy
    and fast to build networks with it. I kind of like it better than visio to build fast drawing. Visio I use for building networks say for a job I am doing
    or maybe a final drawing to show my network off. But for training, I alwasy use network notepad it is free and way easy to use and tons
    of icon templates. http://www.networknotepad.com/ …Yeah get it and look at this guys entire site. when i am rich i am going to donate. this program is super for trianing….Been busy but you can email me man if you want to at my robert@itdaddy.net anytime to ask me a question. I do look at my comments that come to my emai from my new blog. but we both buds studying ccna you can email me direct if you would like.
    -itdaddy (robert) 😉

  3. Edwin Jean Says:

    Great Article! I’ve been looking for some explanations for this topic for a while. I have one question though, would you say using the frame-relay route commands are simpler being that you configure them on the frame relay switch compared to the frame-relay map ip commands because it looks like you have to configure them on the frame relay switch as well as the other routers?

    • Edwin
      thanks about the comments you left but this is the breakdown.
      Frame-relay route commands are only done on the frame-relay switch

      Frame-relay map ip (static mapping of dlci)
      frame-relay interface-dlci (dyamic mapping using APR– that is why we shut it off using no frame-relay inverse arp)

      get it? where do you see anyone using frame-relay route on a DTE interface of the frame-relay system?
      i have only known engineers to use the above?
      frame-relay is all easy you are luck you didnt have to do ISDN (dialer strings) now those are harder!
      let me know where you have seen frame-relay route on a DTE side???I have only seen frame-relay interface-dlci
      and frame-relay map ip. each is for a specific purpose dynamic mappings/and static mappings of dlci. Look
      at DLCIs as airport terminals and planes flying in the cloud to each terminal. Frame-relay is easy. just simplify!
      thanks for your comments
      robert(itdaddy)

  4. Edwin Jean Says:

    Sorry got myself confused there. I meant that the frame-relay route (dlci) interface port (dlci) commands go on the frame relay switch. Which is the DCE side. Here’s an example of a config to kind of show what I’m talking about.

    This would be a Hub and Spoke using the frame-relay route (dlci) interface port (dlci) command. Where R1 is the Hub and R2 and R3 is the spoke.

    frame-relay switching
    !

    interface Serial1
    no ip address
    no ip directed-broadcast
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    clockrate 56000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 122 interface Serial2 221
    frame-relay route 123 interface Serial3 321
    !
    interface Serial2
    no ip address
    no ip directed-broadcast
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    clockrate 56000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 221 interface Serial1 122

    interface Serial3
    no ip address
    no ip directed-broadcast
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    clockrate 56000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 321 interface Serial1 123

    And I believe this would be static mappings to achieve the same thing

    R1
    interface serial 0
    no frame-relay inverse-arp
    frame-relay map ip 10.0.0.2 122 broadcast
    frame-relay map ip 10.0.0.3 123 broadcast

    R2
    interface serial 0
    no frame-relay inverse-arp
    frame-relay map ip 10.0.0.1 122 broadcast

    R3
    interface serial 0
    no frame-relay inverse-arp
    frame-relay map ip 10.0.0.1 122 broadcast

    Is there any difference other that one is dynamic and the other is static?

    • Edwin
      your configs look fantastic. Studying with Chris bryant huh? configs looks same. hee hee.
      But yeah, you have it right. It is good to get confused man. and by you writing your configs out and teaching me what you know, only makes it stick even more and makes your mind clearer. Great configs and great job man! the frame relay route command is on the mock frame relay switch while the other two are static and dynamic mappings. and as far as the big difference. I really dont think there is a difference except dynamic uses ARP and static uses the no inverse-arp command.
      To me it is only options to use. Some prefer static and some prefer dynamic. I do believe most engineers prefer static.. happy configging man! Keep the questions comming any time.

      Robert(aka itdaddy)

  5. Edwin Jean Says:

    Lol. Yep I did get those configs on his website. Thanks for the clarification I feel at ease and I can be able call it a night now. This frame stuff was driving me crazy. Actually one more thing with the frame relay map ip statments there’s no need to have a frame relay switch am I right. You would just have to connect the routers together via serial

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: