Archive for April, 2008

HSRP – Hot Swappable Routing Protocol (fail-over)

Posted in HSRP Protocol (fail-over) on April 25, 2008 by itdaddy

 

 

************************
R1 Config
***********************

Note: below commands all done in interface config mode

interface ethernet 0

ip address 1.0.0.1 255.0.0.0

standby 1 ip 1.0.0.3

standby 1 preempt

standby 1 priority 110

standby 1 authentication denmark

standby 1 timers 5 15

Note:all commands below done in router config mode

router eigrp 1

network 1.0.0.0

************************
R2 Config
***********************

Note: all commands below done in interface config mode

interface ethernet 0

ip address 1.0.0.2 255.0.0.0

standby 1 ip 1.0.0.3

standby 1 preempt

standby 1 authentication denmark

standby 1 timers 5 15

Note: all commands below done in router config mode

router eigrp 1

network 1.0.0.0

 **********www.cisco.com the below taken from*********

The Standby IP interface configuration command enables HSRP and establishes 1.0.0.3 as the IP address of the virtual router. The configurations of both routers include this command so that both routers share the same virtual IP address. The 1 establishes Hot Standby group 1. (If you do not specify a group number, the default is group 0.) The configuration for at least one of the routers in the Hot Standby group must specify the IP address of the virtual router; specifying the IP address of the virtual router is optional for other routers in the same Hot Standby group.

The standby preempt interface configuration command allows the router to become the active router when its priority is higher than all other HSRP-configured routers in this Hot Standby group. The configurations of both routers include this command so that each router can be the standby router for the other router. The 1 indicates that this command applies to Hot Standby group 1. If you do not use the standby preempt command in the configuration for a router, that router cannot become the active router.

The standby priority interface configuration command sets the router’s HSRP priority to 110, which is higher than the default priority of 100. Only the configuration of Router A includes this command, which makes Router A the default active router. The 1 indicates that this command applies to Hot Standby group 1.

The standby authentication interface configuration command establishes an authentication string whose value is an unencrypted eight-character string that is incorporated in each HSRP multicast message. This command is optional. If you choose to use it, each HSRP-configured router in the group should use the same string so that each router can authenticate the source of the HSRP messages that it receives. The “1” indicates that this command applies to Hot Standby group 1.

The standby timers interface configuration command sets the interval in seconds between hello messages (called the hello time) to five seconds and sets the duration in seconds that a router waits before it declares the active router to be down (called the hold time) to eight seconds. (The defaults are three and 10 seconds, respectively.) If you decide to modify the default values, you must configure each router to use the same hello time and hold time. The “1” indicates that this command applies to Hot Standby group 1.

*********************************************

*********************************************
HSRP
Go to this link – Nice Cisco Workup of HSRP
Click link below. Download to your PC and Save/Print it out.
It is from Cisco.com website.  Teaches HSRP. 
https://itdaddy.files.wordpress.com/2008/04/hsrp.pdf
*********************************************

You Tube HSRP free video freaking awesome Click below link!

http://www.youtube.com/watch?v=2-EtRgAEHiE

***********************************************************************************

 

 

Advertisements

Subnetting the Easy Way! 1-2-3 Done!

Posted in Subnetting the Easy way!! on April 22, 2008 by itdaddy

Practice Subnetting daily at your job! _ Easy with this site!

 

 http://www.subnettingquestions.com/default_int.asp

 

 

I practice every day with this and man can you get good at subnetting!

Every day use this site for 1 hour at work and watch your successes!

 

freaking  awesome !!!!!!!!!!!!!!!!

 

 

 *******************************************
* IPSubnetter v1.2 great tool
* to verify you answers subnetting
* Click here to download
http://bosondownload.com/utils/bos_sub.exe
*********************************************

Practice Problems: Finding Subnets  

Practice Problems: Finding Hosts      

      http://nuggetlab.com/cisco/ccent_1.zip      

 

                                                  

Memory Cold items you must know:

 

2^n-2=Hosts  cannot use first host (network) and last host (broadcast)

2^n=Subnets (ip subnet zero no -2)  can have 000 and all 111s subnet

 

Note: Prior to 12.0 IOS by default, you could not use the all 0s or all 1s address because they were the Network ID and Broadcast Address. But 12.0 IOS and beyond the command ip subnet-zero is enabled by default. So no longer do you subtract a “2” if they specifiy it. In the Cisco exams Daved Davis says they will give you enough information to know when to use the 2^n-2=hosts or when to use the 2^n. They will give you enough information to know.  

 

Memorize these:

 

2^10=1024

2^6=64

2^5=32

2^3=8………………..number doubles as add 1 to N

2^2=4

 

 

Classes A, B, C, D
 

A – 1-126…………………127 loopback reserved.

B – 128-191

C – 192-223  

D – 224                    multicast 

 

Non-Routable addresses:

 

10.0.0.0 – 10.255.255.255          255.0.0.0  /8

172.16.0.0-172.31.255.255         255.240.0.0 /12

192.168.0.0-192.168.255.255     255.255.0.0  /16

 

 

APIPA (automatic private ip address)

 

169.254.0.0  255.255.0.0 /16 

your machine assignes you this if it cannot find a DHCP server or no STATIC ip is found.

Windows Machines are known for this.

 

 

Loopback Address:(on Computers)

 

127.0.0.1 or localhost DNS name

127.123.3.240 can be loopback adapter as well.

this is used to test your NIC card.

 

 

Network ID and Broadcast in a subnet range:

 

(Network ID)  (Broadcast)……………what is left in the middle is usable IPs

192.168.1.0 – 192.168.1.255…………except where “ip subnet-zero” is used.

192.168.2.0 – 192.168.2.255

192.168.3.0 – 192.168.3.255

192.168.4.0 – 192.168.4.255

 

 

Subnetting TO

 

 

1. Find Number of Subnets/Networks (words used interchangablely)

2. Find Number Hosts 

 

******************************************************************************************** 

Find Number of Subnets 

********************************************************************************************

 2^n=Subnets

 

*********************************************

Question 1:

*********************************************

 

216.21.5.0  /24
CLASS C
SUBNETS NEEDED = 5

 

1. # OF NETWORK BITS?

1 6 3 1 8 4 2 1
2 4 2 6
8
——————
0 0 0 0 0 1 0 1  = 3 BITS FOR 5 SUBNETS    

2.  BITS TO MAKE MASK-INCREMENT
           
            1 6 3
            2 4 2
            8
255.255.255.1 1 1 00000

Inrement= 32

*Note: with no ip subnet-zero you have
30 usable hosts in below example.

 

3. USE INCREMENT TO FIND NETWORK-RANGE
(network id –   broadcast )     
216.21.5.0   –  216.21.5.31     1
216.21.5.32  –  216.21.5.63     2
216.21.5.64  –  216.21.5.95     3
216.21.5.96  –  216.21.5.127    4
216.21.5.128 –  216.21.5.159    5  Total subnets

 *********************************************

Question 2:

 *********************************************

195.5.20.0
class c
need 50 networks/subnets

 

1. binary-bits

 

1 6 3 1 8 4 2 1
2 4 2 6
8
—————–
0 0 1  -> 6    *quick counts bits to 1
               50 = 6 bits done!

 

2. bits mask-increment

 

class c
255.255.255.11111100 
2 host bits left
6 subnet bits used
255.255.255.252 mask used
255-3=252

increment = 4

 

3. increment-range

 

2 usable
2 not used
4 usable if “ip subnet-zero” used
(network id  –  broadcast address)
195.5.20.0   –  195.5.20.3
195.5.20.4   –  195.5.20.7
195.5.20.8   –  195.5.20.11
195.5.20.12  –  195.5.20.15
195.5.20.16  –  195.5.20.(20-1)

 

 ********************************************* 
Question 3:     

 *********************************************

150.5.0.0
Class B
255.255.0.0 /16
Need 100 Subnets

 

1. binary->bits


1 6 3 1 8 4 2 1
2 4 2 6
8
——————
  1 1 -> 7 bits needed

 

2. bits->mask->increment

255.255.11111110.00000000
255.255.254.0 /23
increment= 2

 

3. increment->range

 

(network id – broadcast)
150.5.0.0  – 150.5.1.255
150.5.2.0  – 150.5.3.255
150.5.4.0  – 150.5.5.255
150.5.6.0  – 150.5.x.y

*********************************************

Question 4:

*********************************************

 

need 500 networks/subnets
10.0.0.0
class A    /8
255.0.0.0

 

1. binary->bits

5 2.1 6 3 1 8 4 2 1
1 5 2 4 2 6
2 6 8
—————-
  1 1 ->9 bits = 500 networks 
 
  2^9-2=510

 

2.bits->mask->increment

 

255.0.0.0
/8    –> /17
255.255.128.0
255.11111111.10000000.00000000
place = 128 increment = 128

 

3.increment->ranges

 

10.0.0.0       – 10.0.127.255
10.0.128.0   – 10.0.255.255
10.1.0.0       – 10.1.127.255
10.1.128.0   – 10.1.255.255
10.2.0.0       – 10.2.127.255
10.2.128.0   – 10.2.255.255

 

 ************************************************************************************************

Find Number of Hosts 

 ************************************************************************************************

2^n-2=Hosts

2^n=Host (ip subnet-zero used) 

 

 ******************************
 Question 1:  
*******************************
216.21.5.0 /24
class c
need 30 hosts per subnet

 

1. binary->bits

1 6 3 1 8 4 2 1
2 4 2 6
8
—————–
0 0 0 1 1-> 5 bits = 30 host binary

means in this case
5 bits or 0s for host.

 

2.bits->mask->increment

 

5 bits to make subnet mask
class c = 255.255.255.0
255.255.255.11100000  (5bits for hosts)
2^5-2= 32 hosts = 30 host met!
2^3=8 subnets

3.increment->range

(network id   – broadcast address)
           30 hosts
216.21.5.0    –   216.21.5.31
216.21.5.32   –   216.21.5.63
216.21.5.64   –   216.21.5.95
216.21.5.96   –   216.21.5.127
216.21.5.128  –   216.21.5.159
216.21.5.160

 **************************************************

Question 2:

***************************************************

 

hosts->50

195.5.20.0
class c
255.255.255.0

1. binary->bits

1 6 3 1 8 4 2 1
2 4 2 6
8
—————–
0 0 1 1->6bits to make 50 hosts

 

2.bits->mask->increment

255.255.255.11000000
increment = 64
255.255.255.192
/26

 

3.increment->range

(network id   – broadcast address)
   
195.5.20.0      – 195.5.83.255
195.5.84.0      – 195.5.147.255
195.5.148.0     – 195.5.211.255
195.5.212.0     – 195.5.x.y

(2^6-2)=62   hosts = 60
2^2= subnets

 

********************************************

Question 3:

********************************************

150.5.0.0
class B
255.255.0.0

hosts->500 per subnet

1. binary->bits

 

2 1 6 3 1 8 4 2 1
5 2 4 2 6
6 8
—————–
1 ->9 BITS TO = 500
2^9-2=510

2.bits->mask->increment

255.255.11111110.00000000
255.255.254.0
/23
increment = 2

3.increment->range

(network id   – broadcast address)
150.5.0.0  – 150.5.1.255
150.5.2.0  – 150.5.3.255
150.5.4.0  – 150.5.5.255
150.5.6.0  –

2^9-2 = 510 host
2^7   =  128 = subnets/networks

 

******************************************

Question 4:

******************************************

 10.0.0.0
class A
255.0.0.0
hosts->100

1. binary->bits

 

1 6 3 1 8 4 2 1
2 4 2 6
8
—————–
0 1->7 bits to make 100 hosts

 

2.bits->mask->increment

255.11111111.11111111.10000000
255.255.255.128 /25
increment = 128

3.increment->range

(network id   – broadcast address)

10.0.0.0       –   10.0.0.127
10.0.0.128     –   10.0.0.255
10.0.1.0       –   10.0.1.127
10.0.1.128     –   10.0.1.255
10.0.2.0       –   10.0.2.127
10.0.2.128     –   10.0.2.255

2^7-2 = 126 hosts
2^17 =  131072 subnets
*********************************************************************************

Subnetting VLSM The Easy way!!!

*********************************************************************************