Archive for July, 2008

7 August 2008 CCNA 802 Exam Set!

Posted in CCNA Study List hot! on July 16, 2008 by itdaddy
Advertisements

IPv 6 Basics Run Down

Posted in IPv6 Holy Crap! on July 15, 2008 by itdaddy

How to configure IPV6 on a router

R1(config)#ipv6 unicast-routing      /enables ipv6 routing on all interfaces

                       (isp prefix 48 bits) (subnet 16 bits) (Interface ID/host ID 64 bits)

R1(config-if)#ipv6 address 2233:0:2222:11:0000:0000:0000:0001/64

Note: can have ipv6 and an ipv4 address on one interface.

Show command:

show interfaces

show ipv6 interface fa0/0

show ipv6 interface brief

show ipv6 router connected

IPv6 Break down:
IPv4 address:
128.102.11.0   /24
128.102 is the network id portion
11 is the subnet id
0 is the host id
Class B address which is /16
Hosts in this case is easy:    32 – 24 = host bits = 8 = 2^8-2= 256-2= 254 hosts
Subnet                            24-16 = 8 bits = 2^8 =256 subnets
————————————–
IPv6 similarities:
2233:0000:2222:0011:0000:0000:0000:0000/64
2233:0000:2222:0011              :0000:0000:0000:0000/64 being used.
(isp prefix 4 x 16 bit quartets( 0011 is subnet intranet))  (last 4 quartets is

interface ID/Host ID)
How to abbreviate IPv6:
Example: 2233:0000:2222:0011:0000:0000:0000:0000/64
    2233:0000:2222:11:
    2233:0:2222:11::/64
1. leading zero of a quartet can be omitted
2. All quartets can be abbreviated 0000 to :0:
3. 1 instance of multiple 0000:0000 to ::

 

 

 

 

Run show commands to see running-config and how you can dual IPv4 with IPV6 on same interface. Cool huh!

R1#show running-config        /out put below.

——some out surpressed for ease of reading——

ipv6 unicast-routing
no ftp-server write-enable
!        
!
!
!
!
!
!
interface Loopback0
 no ip address
!
interface Ethernet0
 description LAN inside$FW_INSIDE$
 ip address 192.168.15.77 255.255.255.0
 ip access-group 100 in
 ip nat inside
 ip virtual-reassembly
 ipv6 address 2233:0:2222:11::1/64
 no cdp enable
 hold-queue 32 in

——————————————————-

Show command output here.

R5#sh ipv6 inter e0
Ethernet0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::213:C3FF:FE42:6B6D
  Description: LAN inside$FW_INSIDE$
  Global unicast address(es):
    2233:0:2222:11::1, subnet is 2233:0:2222:11::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF00:1
    FF02::1:FF42:6B6D
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  ND advertised reachable time is 0 milliseconds
  ND advertised retransmit interval is 0 milliseconds
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  Hosts use stateless autoconfig for address

————————————-

Cold Memory:

FF02 is multicast of some sort

FE80 is Link-local address

Global Unicast :2233:0:2222:11::1, subnet is 2233:0:2222:11::/64

————————————-

R5#sho ipv6 inter brief
Ethernet0                  [up/up]
    FE80::213:C3FF:FE42:6B6D
    2233:0:2222:11::1
Ethernet1                  [up/down]
    unassigned
Ethernet2                  [down/down]
    unassigned
FastEthernet1              [down/down]
    unassigned
FastEthernet2              [up/up]
    unassigned
FastEthernet3              [down/down]
    unassigned
FastEthernet4              [down/down]
    unassigned
Loopback0                  [up/up]
    unassigned
R5#

——————————-

R5#show ipv6 route connected
IPv6 Routing Table – 4 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
       U – Per-user Static route
       I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
       O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
       ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
C   2233:0:2222:11::/64 [0/0]
     via ::, Ethernet0
R5#

———————————-

Practice Abbreviatiing IPv6

———————————-

example 1:

2233:0000:2222:0011:0000:0000:0000:0000:/64

2233:0:2222:11::/64
example 2:

2001:0050:0000:0000:0000:0AB4:IE2B:98AA/128

2001:0050::0AB4:IE2B:98AA/128

2001:50::AB4:IE2B:98AA/128
example 3:

1234:1234:0000:0000:0000:0000:3456:3434 /128

1234:1234::3456:3434/128
Types of casts:


(**broadcast is not longer used in IPv6**)
Unicast– 1 to 1

Multicast – 1 to specfic many (example: FF00::/8
 
Anycast -1 to closest device

Types of addresses ipv6:

Global Unicast – similar to Public IP from the ISP

Link-Local  Similar to the MAC address (FE80)
FE80:AAAA.AAAA.AAAA  (FE80 + Mac address)

Site-Local Private addressesing side (FEC0)
Loopback are all 0s and then a 1 like this (::1/128 )
no broadcast in IPv6 any more..

Note: advantage of IPv6 is route summarizing
IPv4 compatible
1st 96 bits used last 16 bits for ipv6 compatible:

ipv6:

:D1 90:4E 71

D1 = 209
90 = 144
4E = 78
71 = 113                    Hex
                                    0-9   = 0 – 9
256 |   16  | 1              A-F   = 10 – 15
——————–
             D     1   = 209
ipv4 compatible:

209.144.78.113

——————————————————
DHCP or Autoconfiguration IPv6 world –RFC 2462 excerpts from below…
—————————————————–

Autoconfiguration:

Stateful – DHCPv6 autoconfiguration – obtian Ipv6 address via server

In the stateful autoconfiguration model, hosts obtain interface
   addresses and/or configuration information and parameters from a
   server.  Servers maintain a database that keeps track of which
   addresses have been assigned to which hosts. The stateful
   autoconfiguration protocol allows hosts to obtain addresses, other
   configuration information or both from a server.  Stateless and
   stateful autoconfiguration complement each other. For example, a host
   can use stateless autoconfiguration to configure its own addresses,
   but use stateful autoconfiguration to obtain other information.
   Stateful autoconfiguration for IPv6 is the subject of future work

Stateless – Static – local host creates its own LINK-Local address

IPv6 defines both a stateful and stateless address autoconfiguration
   mechanism. Stateless autoconfiguration requires no manual
   configuration of hosts, minimal (if any) configuration of routers,
   and no additional servers.  The stateless mechanism allows a host to
   generate its own addresses using a combination of locally available
   information and information advertised by routers. Routers advertise
   prefixes that identify the subnet(s) associated with a link, while
   hosts generate an “interface identifier” that uniquely identifies an
   interface on a subnet. An address is formed by combining the two. In
   the absence of routers, a host can only generate link-local
   addresses. However, link-local addresses are sufficient for allowing
   communication among nodes attached to the same link.

 

How host creates link-local address:

Host sends out (NS) neighbor solicitations to check to see if anyone else is using this link-local address.

NS destination address FF02::1 is a multicast to ALL Nodes!

if NS finds a match of some host using same address host responds with NA neighbor advertisment from responding Host A (NA). The NS host will disable its link-local and retry another link-local address.

So host A sends out NS to host B host B sends back NA host A recalculates link-local address and retries its NS messages until it doesnt find a similar link-local address.

Process is call DAD     Duplicate Address Detetection

—————————

Just the basics for Ipv6

—————————

EIGRP Hybrid Routing Protocol

Posted in EIGRP Hybrid Routing on July 14, 2008 by itdaddy

 EIGRP 

 

– Hybrid distant vector/link state Routing Protocol

 

Topics Discussed:

Success and Feasible successor
EIGRP vs RIPv2
Basic Config
Wild Masks
Load balancing (equal / unequal) Variance cmd
EIGRP/RIPvs and auto summarization
Passive/active routes

Neighbor table – shows neighbors
Topology table – shows successor and feasible successors
Route table – only successor routes and other

Requirements for neighbors to form:

– same subnet
– same AS#
– K-value must match

 

EIGRP Metric

The EIGRP composite metric is computed exactly as the IGRP metric is and then multiplied by 256. Thus, the default expression for the EIGRP composite metric is:

Metric = [BandW +Delay] × 256

 

How EIGRP works (basics)


Why EIGRP is so good a protocol:

1 .Hybrid protocol like distant vector in that when routers first establish
Neighbor adjacencies, they exchange full routing tables then they send updates
Based off of bandwidth/delay cost.

2. IP, IPX, Apple Talk proctol compatible

3. Uses VLSM

4. Cisco proprietary is the down fall.

Cold memory:

Uses 224.0.0.10  and RTP to transmit message to/from EIGRP routers
Uses hello packets
Uses AS# must be same
Uses band/delay as cost metric

Neighbor Adjacencies can exits if:

Hello packets every 5 seconds
Same subnet
k-weights same
Same AS#

 

How EIGRP routing works:

 

Best route into routing table
Topology table hold successor, feasible successor.
Has feasible successor calculated before failure occurs
Uses DUAL algorithm, neighbor Dual query

Multicast address (hello)

Cold Memory:

OSPFv2    224.0.0.5
RIPv2       224.0.0.9
EIGRP      224.0.0.10

 

 

 

Turn off split –horizon and auto-summary.

R1(config)#no ip split-horizon eigrp 100
R1(config-router)#no auto-summary

 

Wild Card mask used EIGRP:

255.255.255.255  subnet mask =  0.0.0.0 as wild card mask.
172.12.123.0 0.0.0.0 is called a host mask wild card
172.12.123.0 255.255.255.255 host mask subnet mask

 

Equal Cost Load balancing EIGRP:

 

R1#show ip router EIGRP
 

Notice AD/Metric are the same for 2 or more rows or routes in route table.
This is Equal cost when the AD/Metric cost are the same.

Variance Command – used in unequal cost load balancing

R1#(conifg-router)#variance (value)

 

FD = Feasible Distance
FD x Variance = Value

Value any metric less than this value, that route will be put into routing table.

2297856 successor
2323456 feasible successor
Variance = 2

2 x FD(2298856)= 4595712

End result is both routes will be in routin table as successors. This is force

unequal cost load balancing. Any route metric in the topology table that is lower

than this variance result value will be put into the route table as a usable

route.

 

Clear ip route *     /clears routing table of all routes and makes protocols recalculate routes.

Auto Summarization – what is it?

Auto summarization is when the router is configured to use auto-summary feature. What that does is insert a summary route into the routing table. This summary Route is a generalization of a bunch of routes. The bad thing about it is it wastes ip addresses. The subnet range could be so large that it encompasses many

routes that could be utilized by your inside LAN. Bottom line – it wastes ip addresses. Auto-summary is on by default and must be shut off.

 

R1#(config-router)no auto-summary

 

EIGRP and RIPv2 must turn off auto-summary. Load balancing paths command: What this is in the routing table you will see say 4 routes that are for the same destination with same AD\Metric this is equal cost load balancing. To limit the number of router possible in the equal/unequal cost load balancing, you can set the limit with these commands.

 

R1(config-router)#maximum-paths 1        /shuts off load balancing
R1(config-router)#maximum-paths 5       /default = 4 max of 16

R1# show ip protocol                           /shows the number of paths set

 

Dual Query and Active/Passive routes (Topology Table):

 

A EIGRP router will use DUAL to query other routers. In the topology table you

will have statuses showing ACTIVE/PASSIVE routes.

ACTIVE –  route can’t be used due to it being used by DUAL in a calculation.

PASSIVE – Good! Dual is not using it in a calculation. Ready to use!

 

R1#show ip eigrp topology              /shows Active/Passive routes in Topology table.

EIGRP metric Calculations:

Cold Memory:
EIGRP Metric

 

The EIGRP composite metric is computed exactly as the IGRP metric is and then multiplied by 256. Thus, the default expression for the EIGRP composite metric is:

Metric = [BandW +Delay] × 256
Metric = 256(10^7/band) + 256(delay+delay)
AD of EIGRP = 90

 

EIGRP manual forced route summary command here – Interface Earlier IOS versions treated changes in EIGRP summary address configuration (configured with the ip summary-address eigrp interface configuration command) very disruptively: all EIGRP sessions across the affected interface were cleared, sometimes resulting in a large number of routes entering active state, potentially leading to a stuck-in-active condition. Recent IOS releases are more lenient: router with a change in summary address requests a resync (logged as graceful-restart on adjacent routers). A lot of updates and queries are still sent, but the adjacencies themselves are preserved:

 

When configuring a summary route, all more specific prefixes on downstream routers enter active state. When a summary is removed, only the summary prefix itself enters active state and the affected router sends queries to all its neighbors, while the more specific prefixes are sent as regular EIGRP updates to the neighbors across the affected interface.

 

A change in EIGRP summary generates the following output on the router under configuration:

Ra1(config)#interface serial 0/0/0.100

Ra1(config-subif)#ip summary-address eigrp 1 0.0.0.0 0.0.0.0
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.1.2 (Serial0/0/0.100) is

resync: summary configured

Ra1(config-subif)#no ip summary-address eigrp 1 0.0.0.0 0.0.0.0
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.1.2 (Serial0/0/0.100) is

resync: summary configured

… and the downstream router generates log messages similar to these:

Rb1#
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.1.1 (Serial0/0/0.100) is

resync: peer graceful-restart

STP 802.1d and RSTP 802.1w Details

Posted in STP vs RSTP on July 13, 2008 by itdaddy

STP and RSTP

 

Spanning-tree protocol:

 

802.1d   STP

802.1w   RSTP

 

Purpose: to prevent switching loops by dropping a tree over Alternate (blocking mode; RSTP) links and in BLK (blocking; STP).

 

Campus model:

 

CORE

Distribution

Access

 

 

 

 

 

 

About STP/RSTP:

 

RSTP – 802.1w

STP – 802.1d

 

What STP/RSTP does is find the best link based off of cost and port priority. Then it drops a tree or block a link that has the most cost. BPDUS has the BID which consists of Bridge Priority.Mac-address. The LOWEST priority plus MAC address of that switch wins the ELECTION for root bridge. However, it is PER VLAN root bridge election. Each VLAN can have its own root bridge. When you first turn on switches, the switches Using STP/RSTP will ELECT the oldest Manufactured switch as the ROOT Bridge.

 

You  can change the Election in a Switches favor by running a few commands.

 

SW1(config)#spanning-tree vlan 1 root primary

 

*what this does is to change the priority to a lower priority than any other priority in the stp domain where it forces the switch you are on and in VLAN 1 to be the lowest root bridge priority which in turn forces the switch you are on to be the Root Bridge per that vlan specified.

 

 

Three ports with STP/RSTP:

 

Root port: use to reach the ROOT bridge (not on root bridge)

 

Designated Port:  FWD port one per link.

 

Alternate/Blocking port: Alternate port if RSTP, Blocking port if STP backup line waiting to be used when primary links go down.

 

 

 

The lowest BID wins election for ROOT bridge.

32768.aaaa.aaaa.aaaa is the lowest BID.

Spanning-tree choosing the best links to use by cost. Below is

A cost chart:

 

Cost                            Bandwidth

 

100                              10 MBps

19                                100 MBps

4                                  1 GBps

2                                  10 GBps

  

 

Tiebreaker routes is based off  of the lower BID (priority.mac-address)

 Cold Memory:

Hello Time = 2 seconds

Max Age = (hello x 10) = 20 seconds

Forward Delay = 15 Seconds

 

 

 

BEST route based of of BID.

Best Route (above) based off of BID. Notice same cost on both sides but lowest BID wins again

for best route.

 

Fact: Oldest Manufacture Date on Switches it is ELECTED root switch unless forced by spanning-tree command.

 

How to Force Root Bridge Election?

 

Sw1(config)#spanning-tree vlan-id root primary

Sw1(config)#spanning-tree vlan-id root secondary

Sw1(config)#spanning-tree vlan-id priority (0-61440 increments of 4096)

 

Explain: what this does is lower the root priority of that bridge so much so it forces it to be  the lowest BID in the switch network to force it to be ROOT bridge. Can create a backup root bridge to insure it is elected when primary root bridge is down.

 

Cold Memory:

Default Secondary root priority is 24576.

Default priority is: 32768

 

 

Cold Memory:

 

50 second recover/failover time using STP

Sub second convergence using failover with RSTP.

 

 

 

Enhancements to STP is RSTP.

 

 

Cold Memory:

RSTP is under 802.1w

STP is under 802.1d

 

 

Cold Memory:

 

Link Modes of STP:

 

Listening  15 seconds listening to BDPUs. Sending/Receiving.

 

Learning  15 seconds learning MAC addresses populating CAM

 

Forwarding – forwarding frames.

 

Blocking – 20 seconds Max Age before moving to blocking mode into Listening

 

Disabled – not normally shown but there is 5 modes/states of STP.

 

Link Modes of RSTP:

 

Discarding –

 

Learning – Learning Source Mac-address-tables for CAM

 

Forwarding –

 

Requirements of RSTP:

To use full features of RSTP you must have these requirements:

 

 

  1. duplex full set on the interface.
  2. point to point network must exist (p2p)
  3. portfast must be set on ports with PCs or servers only(not devices)

 

How to configure SPANNING-TREE PORTFAST.

 

Sw1(config)#int fa0/4

Sw1(config-if)#spanning-tree portfast

 

Explain: this is all you do to set portfast on an interface.DONE!

 

How to set the spanning-tree modes (MST, STP, Rapid-PVST)

 

Sw1(config)#spanning-tree mode ?

Sw1(config)#spanning-tree mode Rapid-PVST

Sw1(config)#spanning-tree mode MST

Sw1(config)#spanning-tree mode STP

 

Sw1(config)#show spanning-tree          

 

Explain: This shows the protocol type for spanning-tree.

 

 

 ==================================

  End of STP vs RSTP

=================================== 

 

 

 

 

 

Cost                            Bandwidth

100                 10   MBps

19                    100 MBps

4                      1     GBps

2                      10   GBps

Cost                            Bandwidth

100                 10   MBps

19                    100 MBps

4                      1     GBps

2                      10   GBps

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Can’t Start Dynamips port 7200????? Answer

Posted in Dynamips/GNS3 Fixes on July 2, 2008 by itdaddy

Hey you dynamips users out there. I have been scratching my heading trying to get my GNS3 to work on my laptop with Ultimate Vista loaded on it. I discovered that my path was wrong in the default configuration of my Dynamips preferences in the preferences drop down menu option in my GNS3 gui. This is what it should be:

C:\Program Files (x86)\GNS3\Dynamips\dynamips-wxp.exe

Read yours carefully and browse to find the dynamips-wxp.exe program don’t just look at the path and say “it looks good” browse for it; it will show to be not there. You need to browse to find the actual program and then click on TEST and it will work.

Phewww!!!

 

Oops! I changed the Config-register now what?

Posted in Config-Register Stuff!! on July 1, 2008 by itdaddy

OOPs I changed the Config-register now what do I do??

oops have you ever tried changing the config-register values for fun to see what they would do?
I have. I changed the config-register values to these:

0x2142 skip NVRAM
0x2102 boot to NVRAM
0x1  rommon (safe mode)
0x0  rom only (very limited IOS

The command to modify the configuration register value is o/r, followed by the new register value. After pressing enter, use

the command i to initialize the router. The i command reloads the router, using the new configuration register setting. In

this case, a configuration register value of 0×2102 ensures that the router will boot as per the factory default settings.

:Use this when in ROM mode only; great to change config register back to booting to NVRAM. I was stuff here awhile trying to find ROM mode only command to change config-register. Phewww! Here it is. This value 2102 changes it bakc to boot normally from NVRAM. Yeah!

>o/r 0x2102
>i

If you issue the break sequence on a Cisco 2600 router, you’ll be presented with the rommon> prompt. Although the commands

from this prompt are a little different, they achieve the same result. In the example below, we’re setting the configuration

register to 0×2142, which tells the router to ignore the contents of the startup configuration file, since bit 6 has been

set. The command to change the configuration register from the rommon> prompt is confreg, followed by the new register value.

To reload the router, issue the reset command.

rommon 1>confreg 0x2142
rommon 2>reset

After issuing the reset command, the router will reboot using the new configuration register value of 0×2142.

Common configuration register settings and their meanings:

0×2102 The default configuration register setting. The break command is disabled, the contents of NVRAM are processed, and

the router will boot according to the commands stored in NVRAM

0×2101 The break command is disabled. The router will process the contents of NVRAM, but will boot into the RxBoot image

stored in ROM.

0×2100 The break command is disabled, and the router will boot into ROM Monitor mode.

0×2142 The break command is disabled, and the router will ignore the contents of NVRAM during the boot process.

0×2002 The break command is enabled, but otherwise the router will boot normally.

====================================

Stop Here.

====================================