Archive for the EtherChannel Trunking Ports Category

Port Channeling – Port Agreggation

Posted in EtherChannel Trunking Ports on May 8, 2008 by itdaddy

 

 

 

Port Channels are a quick way to get more bandwidth by aggregating multiple connections in one virtual pipe. For instance, tie four gigabit ports together into a channel and it becomes a four gigabit connection.

Channels can also offer redundancy fault tolerance for physical connections. If one of the links involved in a channel loses connection, the channel will continue on with the existing ports and three quarters of the bandwidth.

Ports involved in a channel must be on the same blade in a modular switch like a Catalyst 4500 or 6500.

Configuring port channels has become much easier in recent IOS versions. First, designate the desired ports into a channel group.

My_Switch(config)# interface GigabitEthernet2/1
My_Switch(config-if)# description Core Connection
My_Switch(config-if)# channel-group 2 mode desirable

My_Switch(config)# interface GigabitEthernet2/2
My_Switch(config-if)# description Core Connection
My_Switch(config-if)# channel-group 2 mode desirable

The desirable option will create a channel to another Cisco switch in etherchannel format and drop a single channel if necessary. In contrast, using the on option would force a port channel, but would drop the entire channel if a single link.

Etherchannel is Cisco’s proprietary channel protocol, sometimes called PAGP or Port Aggregation Protocol. In order to create channel with a server or non-Cisco switch, the channel will have to be configured in LACP (Link Aggregation Control Protocol) format, which is a multivendor standard.

My_Switch(config)# interface GigabitEthernet2/1
My_Switch(config-if)# description Core Connection
My_Switch(config-if)# channel-group 2 mode passive

My_Switch(config)# interface GigabitEthernet2/2
My_Switch(config-if)# description Core Connection
My_Switch(config-if)# channel-group 2 mode passive

Using the active option instead of the passive mode option will force the ports into a LACP channel without negotiation much like the on option for PAGP. The entire channel will go down if a single line is disconnected and will not be fault tolerant.

 

PAGE 2

Next, create a virtual port channel interface.

My_Switch(config)# interface Port-channel4
My_Switch(config-if)# description Core Connection
My_Switch(config-if)# switchport

The virtual port channel configuration merely controls the aggregate port. For instance, if the port-channel interface is disabled, or shut down as Cisco calls it, then the channel will not work even though all four member ports are enabled.

Display active channels with the show neighbor command.

My_switch> show pagp neighbors

My_switch>show lacp neighbors

The output gives much detail about the channels and their state.

Disable channels

Channels are a handy tool, but most Cisco switches ship in auto mode by default and that can sometimes causes problems with workstations that do not understand how to disregard the channel auto-negotiation. The switchport mode access command disables channel negotiation as well as disabling vlan trunking negotiation. It prepares the port for use by workstations.

My_Switch(config)# interface gig6/5
My_Switch(config-if)# description My favorite PC
My_Switch(config-if)# switchport mode access

NOTE: Channels are often a quick way to add bandwidth and add redundancy with existing hardware.

 *********************************************

Port Aggregation is another name

**********************************************

Port Aggregation in Cisco IOS

Port aggregation (in the cisco world known as channelling) combines two ports for increased bandwidth and link redundancy for connecting switches together.

Router# configure terminal
Router (config)# interface range Gi0/45-46
Router (config-if)# channel-group 1 mode desirable
Router (config-if)# ^Z

This will link ports 45 and 46 (example is on a 2960 switch) together and assign them to group 1. By setting the link mode to desirable, the ports negotiate the proper PAgP protocol. This example configures a group a of ports at the same time. You can always configure each port individually by using the standard “interface Gi0/45” command. Once ports are assigned to a channel group, you can add configuration options to all ports by adding them to the channel. To configure the channel, use the following command: “interface port-channel 1”. The channel group number is unique on the switch. Both switches need to be configured the same, though the channel number does not need to match. When choosing which ports to use for channeling, be sure to choose ports not sharing switch bandwidth to ensure maximum throughput. Ensure that spanning-tree is on in order to prevent loops.

Advertisements

EtherChannels with trunks ports and WHY?

Posted in EtherChannel Trunking Ports on May 5, 2008 by itdaddy

 

****************************************

www.thebryantadvantage.com

Chris Bryant Teaches CCNA and CCNP great Computer base training. I have his stuff!!!

****************************************

 

CCNA and CCNP candidates are well-versed in Spanning-Tree Protocol, and one of the great things about STP is that it works well with little or no additional configuration. There is one situation where STP works against us just a bit while it prevents switching loops, and that is the situation where two switches have multiple physical connections.

You would think that if you have two separate physical connections between two switches, twice as much data could be sent from one switch to the other than if there was only one connection. STP doesn’t allow this by default, however in an effort to prevent switching loops from forming, one of the paths will be blocked.

SW1 and SW2 are connected via two separate physical connections, on ports fast0/11 and fast 0/12. As we can see here on SW1, only port 0/11 is actually forwarding traffic. STP has put the other port into blocking mode (BLK).

SW1#show spanning vlan 10

(some output removed for clarity)

Interface Role Sts Cost Prio.Nbr Type

Fa0/11 Root FWD 19 128.11 P2p

Fa0/12 Altn BLK 19 128.12 P2p

While STP is helping us by preventing switching loops, STP is also hurting us by preventing us from using a perfectly valid path between SW1 and SW2. We could literally double the bandwidth available between the two switches if we could use that path that is currently being blocked.

The secret to using the currently blocked path is configuring an Etherchannel. An Etherchannel is simply a logical bundling of 2 – 8 physical connections between two Cisco switches.

Configuring an Etherchannel is actually quite simple. Use the command “channel-group 1 mode on” on every port you want to be placed into the Etherchannel. Of course, this must be done on both switches if you configure an Etherchannel on one switch and don’t do so on the correct ports on the other switch, the line protocol will go down and stay there.

The beauty of an Etherchannel is that STP sees the Etherchannel as one connection. If any of the physical connections inside the Etherchannel go down, STP does not see this, and STP will not recalculate. While traffic flow between the two switches will obviously be slowed, the delay in transmission caused by an STP recalculation is avoided. An Etherchannel also allows us to use multiple physical connections at one time.

Here’s how to put these ports into an Etherchannel:

SW1#conf t

Enter configuration commands, one per line. End with CNTL/Z.

SW1(config)#interface fast 0/11

SW1(config-if)#channel-group 1 mode on

Creating a port-channel interface Port-channel 1

SW1(config-if)#interface fast 0/12

SW1(config-if)#channel-group 1 mode on

SW2#conf t

Enter configuration commands, one per line. End with CNTL/Z.

SW2(config)#int fast 0/11

SW2(config-if)#channel-group 1 mode on

SW2(config-if)#int fast 0/12

SW2(config-if)#channel-group 1 mode on

The command “show interface trunk” and “show spanning-tree vlan 10” will be used to verify the Etherchannel configuration.

SW2#show interface trunk (some output removed for clarity)

Port Mode Encapsulation Status Native vlan

Po1 desirable 802.1q trunking 1

SW2#show spanning vlan 10 (some output removed for clarity)

Interface Role Sts Cost Prio.Nbr Type

Po1 Desg FWD 12 128.65 P2p

Before configuring the Etherchannel, we saw individual ports here. Now we see “Po1”, which stands for the interface “port-channel1”. This is the logical interface created when an Etherchannel is built. We are now using both physical paths between the two switches at one time!

That’s one major benefit in action let’s see another. Ordinarily, if the single open path between two trunking switches goes down, there is a significant delay while another valid path is opened – close to a minute in some situations. We will now shut down port 0/11 on SW2 and see the effect on the etherchannel.

SW2#conf t

Enter configuration commands, one per line. End with CNTL/Z.

SW2(config)#int fast 0/11

SW2(config-if)#shutdown

3w0d: %LINK-5-CHANGED: Interface FastEthernet0/11, changed
state to administratively down

SW2#show spanning vlan 10

VLAN0010

Spanning tree enabled protocol ieee

Interface Role Sts Cost Prio.Nbr Type

Po1 Desg FWD 19 128.65 P2p

SW2#show interface trunk

Port Mode Encapsulation Status Native vlan

Po1 desirable 802.1q trunking 1

The Etherchannel did not go down! STP sees the Etherchannel as a single link therefore, as far as STP is concerned, nothing happened.