Archive for the Frame-Relay Commands Category

Frame-relay the final frontier!

Posted in Frame-Relay Commands on July 21, 2008 by itdaddy

————————
Frame-relay
————————

facts:

CIR = committed information rate guaranteed bandwidth.
DTE = default of cisco routers
DCE = ISP side of the serial interface (clock rate)
PVC = permanent virtual circuit
SVC = switches virtual circuit
NBMA = non-broadcast multiaccess Topology
Broadcast = ethernet broadcast topology.
PVC full mesh
PVC partial mesh
Hub and spoke topology.
————————
———————————
lmi – heartbeat hello keepalive
———————————

lmi = local management interface message.
DCE(clock rate) –> DTE (default router)
PVC status – Active/Inactive.

3 lmi types
cisco
ansi
q933a

—————————
lmi autosense used:
—————————
The DTE device pumps 3 lmi types to the DCE and then the DCE
returns the correct lmi type and then both agree and keep correct lmi type.
config-if)#frame-relay lmi-type (cisco, ansi, q933a)

——————————————————-
About the DLCI
——————————————————-

DCLI layer 2
locally used  or locally significant
could use same DCLI on all routers
airplane theory example (gates to fly into)

Dynamic- inverse-ARP is used.
frame-relay interface-dlci 123
Static – Static
frame-relay map ip (remote ip)(local dlci) broadcast
split-horizon issues on frame-relay
pic of hub spoke and split-horizon
R2 R1 R3. Router 2 sends updates to R1 and then R1 has to then send update
out same interface to R3. split-horizon prevents this.

————-
subif

– multipoint
– point-to-point
Split-horizon turn off/on at interface level:

int serial0
config-if)#ip split-horizon
config-if)#no ip split-horizon
—————————
Show frame-relay pvc satus
—————————-

#show frame-relay pvc status

Active – all working
Inactive – remote device not config correctly.
Deleted – Local issue on router.

—————————————————
Pic of frame hub and spoke Lab
—————————————————


———
R1 Config
———
interface Serial1
 description Points to R1 and R2
 no ip address
 encapsulation frame-relay
 ip split-horizon
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1.12 point-to-point
 ip address 172.12.123.1 255.255.255.252
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 ccie
 ip ospf network non-broadcast
 frame-relay interface-dlci 112  
!
interface Serial1.13 point-to-point
 ip address 172.12.123.5 255.255.255.252
 ip ospf network non-broadcast
 frame-relay interface-dlci 113  

———
R2 Config
———
interface Serial1
 description Points to R1
 ip address 172.12.123.2 255.255.255.252
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 ccie
 ip ospf priority 0
 frame-relay map ip 172.12.123.1 211 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

———-
R3 Config
———-
interface Serial1
 ip address 172.12.123.6 255.255.255.252
 encapsulation frame-relay
 ip ospf priority 0
 frame-relay map ip 172.12.123.5 311 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
——————
Multipoint example – similar to physical serial interface.
——————
interface Serial1
 description Points to R1 and R2
 no ip address
 encapsulation frame-relay
 ip split-horizon
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
interface Serial1.14 multipoint
 ip address 172.12.123.18 255.255.255.252
 frame-relay map ip 172.12.123.6 112 broadcast

frame-relay map ip x.x.x.x dlci broadcast OR frame-relay interface-dlci

Posted in Frame-Relay Commands on March 17, 2008 by itdaddy

 =============================
frame-relay show commands
=============================
R2#sh frame lmi
LMI Statistics for interface Serial1 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 14               Num Status msgs Rcvd 14
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:47         Last Full Status Rcvd 00:00:47
R2#sh frame pvc
PVC Statistics for interface Serial1 (Frame Relay DTE)
              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0
DLCI = 221, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1.123
  input pkts 0             output pkts 0            in bytes 0        
  out bytes 0              dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 0         out bcast bytes 0        
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 05:30:57, last time pvc status changed 00:21:00
R2#sh frame map
Serial1.123 (up): ip 172.12.123.1 dlci 221(0xDD,0x34D0), static,
              broadcast,
              CISCO, status defined, active
Serial1.123 (up): ip 172.12.123.3 dlci 221(0xDD,0x34D0), static,
              broadcast,
              CISCO, status defined, active
R2#
==============================
============================== 
 

 

frc3-4fin.png

 

 

 

 

My View on Frame-Relay:

Frame-relay can be very weird.  The hard thing about frame-relay is “which frame-relay command do I use?” is the question.

The answer to the question is simple: You can use which one you want as long as all the PVC mappings are complete and connect to the correct router interface.  You can mix and match frame-relay commands. Just run a ping command to each PVC (ip address) and run your debug commands:

show frame map – Should see word “Active”  if working well.
show frame pvc   –
show frame lmi    –  Sent/Received should be equal amount if working

Static Mappings Command:

frame-relay map ip (remote ip address) (local dlci) broadcast

frame-relay map ip 172.12.123.1 201 broadcast

NOTE: Broadcast is used with this command to allow RIP updates to work. But, if “frame-relay inverse-arp” is used and inverse-arp is turned on, then the command “broadcast” is not needed.

Dynamic Mappings Command:

frame-relay interface-dlci (local dlci) 

frame-relay interface-dlci 201

frame-relay inverse-arp (enabled)

NOTE: frame-relay inverse-arp used to allow for dynamic mappings. 

If you look at the drawing I have given you, it explains the difference between the “actual” and the “virtual/logical” layout of the frame-relay setup. What you see is not what you actually get. When I first saw the “Full-Mesh” I thought there were three actual physical ports on each router. This is not true. You have instead 3 virtual or 3 sub-interfaces on each router that set up a PVCs to each router. I think this is essential when teaching or learning frame-relay. Remember that they are virtual/logical mappings not separate physical ports.

NOTE: You need ‘broadcast’ command with “frame-relay map ip” command when using RIPv1 since it uses broadcasts to send out routing table information.

NOTE: The hard thing now is to know when to use the right frame-relay command mentioned above and which type of port setup:

Port setup types:                                              Example:

Serial Port only                                                  Serial0
Serial Port with Multipoint option                       Serial0.1 multipoint
Serial Port with Point-to-Point option                Serial0.1 point-to-point

Other important Commands:

no frame-relay inverse-arp

You need “broadcast” command to allow RIP updates to  take place.

frame-relay inverse-arp

No need for “broadcast” command here. 

frame-relay lmi-type (ansi, cisco, q933a)

 Keep lmi types the same on both ends. 

encapsulation frame-relay (can use – “ietf”)

Keep encap “frame-relay” for frame-relay connections

 

Example of R1 (Full-mesh) Frame-relay topology:

frc-1f.png

 

 

 

 

Subinterfaces on R1:

R1(config)#interface serial 0

R1(config-if)#encapsulation frame-relay

R1(config-if)#no shutdown

R1(config-if)#interface serial0.200 point-to-point

R1(config-subif)#frame-relay interface-dlci 102

R1(config-subif)#ip address 172.16.1.1 255.255.255.0

R1(config-subif)#no shutdown

———————————-

R1(config-if)#interface serial0.300 point-to-point

R1(config-subif)#frame-relay interface-dlci 103

R1(config-subif)#ip address 172.16.3.1 255.255.255.0

R1(config-subif)#no shutdown

———————————

R1(config-if)#interface serial0.400 point-to-point

R1(config-subif)#frame-relay interface-dlci 104

R1(config-subif)#ip address 172.16.4.1 255.255.255.0

R1(config-subif)#no shutdown

 ————————————————————–

Frame Relay YouTube nice! Below (Double Click to expand video Full Screen

————————————————————–

 www.palaestratraining.com

 

H2o Fuel…Answer to get rid USA dependency on OPEC oil–OPEC Sucks!!!